Jump to content

Check your fuel lines!


Ntenna
 Share

Recommended Posts

Avanti production began almost 60 years ago. Since then cars have received total restoration, been totaled and everything in-between.

If you haven't checked your fuel lines recently, look at these photos. This is not only the main tank feed over the axle, but the return and vent hoses behind the rear seat. They pretty much tell the story. Getting that vent line upper U-turn out and replaced is really fun. And this is a good running, show-level R-2. A failed pump diaphragm started me replacing everything.IMG_1656.thumb.jpeg.bf0f808a578598b0361d178875bf7dd0.jpeg

IMG_1659.thumb.jpeg.bb74da1560dacf4ba344045df0003c3f.jpegIMG_1664.thumb.jpeg.1f10e22fc1e38e5b992b74556eb9f549.jpeg
Link to comment
Share on other sites

I ran a wire inside the vent hose in the 1/4 and used it to fish the new line back through the high loop in the 1/4 panel.

Link to comment
Share on other sites

Sounds good, Brad. Planning on the same.

When I cut the vertical run and pulled the horizontal vent line out, I found the copper pipe was cut too long at the factory, and the flex line going up into the 1/4 panel was crimped shut against the copper pipe. Been folded over since new. Plus now cracked at the top of the U and tank coupler.

If anyone has issues with the tank spitting back while fueling, there's the problem. This one did, and it will hopefully now do it less or not at all. Pictures coming.

Link to comment
Share on other sites

I would get a smell of gas in the car every time I filled up the tank.

Found that the fittings were not soldered all the way around. The tank fill tube at the base was leaking and the vent fittings were leaking.

These were not cracked, just poor soldering. Took it to my radiator shop and had it repaired.

If you can get to the tank I would test it for bad joints.

Good luck,

Jim Wood

Link to comment
Share on other sites

7 hours ago, Ntenna said:

Sounds good, Brad. Planning on the same.

When I cut the vertical run and pulled the horizontal vent line out, I found the copper pipe was cut too long at the factory, and the flex line going up into the 1/4 panel was crimped shut against the copper pipe. Been folded over since new. Plus now cracked at the top of the U and tank coupler.

If anyone has issues with the tank spitting back while fueling, there's the problem. This one did, and it will hopefully now do it less or not at all. Pictures coming.

Really makes you feel good to find (and correct) something like that!:)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...