Jump to content

1982 Avanti Transmission Speed Sensor.


Stuart Boblett
 Share

Recommended Posts

Hell folks, I have another difficult problem that I need your help on. On the side of the Automatic OD transmission there is a "device" that installs into the transmission and the speedometer cable and a couple wires connect to it. I thought initially that it was a cruise control sensor but have been advised that it is a "Speed Sensor" that connects to the computer. I was told that these were specifically made for Avanti and are hard to come by. Mine is leaking transmission fluid and supposedly that is a symptom for failure in the near future throwing a check engine light. The cost of these is about $500. dollars which really crazy. Is anyone familiar with these devices, had problems and have any suggestions? Thanks a bunch, this has got me flabbergasted and I can find no reference to it elsewhere in this forum. 

Link to comment
Share on other sites

Interesting as yours is a year older than my 83 and, I believe, you have the TH 350/400 3-speed auto. The 700R4 from my 83 only has a mechanical speedo cable connector in the tail shaft so if your part exists NOS it must be real rare part. Mine must pickup speed from the timing/tach setup. 

IAC, when I bought mine it ran kinda OK but was a dog and had acceleration issues. I just replaced the ECM setup with a carb and eventually a performance engine with EFI. 

I'm surprised any part you would need is not available as Avanti used SBC's as they were already smog legal so I would think they would use basically GM electronics also to keep the smog certs.

Post a picture of what you have if possible and IIWM, I'd Google for a lot of info on the GM setups for 81/82 for reference.

One last comment. The computer harness and controls in your car are essentially a stand alone harness as I found out when I eliminated my stock ECM setup so I just pulled the whole set up out. Yielded a lot of good wiring for other projects. I don't recommend this approach if you don't like to do auto wiring, however.

Link to comment
Share on other sites

  • 2 weeks later...

Back to the transducer / speed sensor or whatever it is, here are some pictures. I am not sure if this is a part just on the 82 with the electronic carb or cruise control or what. Help guys, any ideas.IMG_2152.thumb.jpg.240801b81fc5bd006d6cfc911b9bb490.jpg

IMG_2150.jpg

IMG_2151.jpg

Link to comment
Share on other sites

The spiral blue/??? colored wire pair in the pictures are usually the speed sensor wires to an aftermarket (Dana/Rostra) cruise control. They appear to be cut off in one picture above but IAC my opinion is that the box in the speedo cable assembly is a wave generator for the cruise control and not part of the engine control system. 

The way to check is to remove it, reconnect the speedo cable and see if it creates issues. My money is on no issues.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...