Jump to content

1989 Cruse control speed sensor mfg by MassTech


89conv
 Share

Recommended Posts

My cruise stoped working and the engine light came on. After running the tests it showed up as the speed sensor, which is located betweend the cable from the trans and the cable to the speedo. It joins the two cables together and has two wires that plug into the harness. I was told that the sensor is a after market product used by Avanti Motors. The only ID is the word Mass Tech. Does any one know where to find one like this or something else that may work.

Rich

Edited by 89conv
Link to comment
Share on other sites

GM calls that part the transducer. It may be the same part used on Corvettes (I replaced one on a '78 Vette). Look at Corvette Central, Eckler's, Corvette America websites for C3 and C4 generation Corvettes and see if the part looks the same. I believe they came in 2- and 3-wire applications. I don't know if it is, but it may work equally well since you have a GM engine and transmission. A transducer runs about $100 depending on where you get it from.

Link to comment
Share on other sites

I replaced mine in my 84 with a 700R4 transmission with one for a Camero two wire. I t worked fine but was a little close to install.

Charlie RQB3921

Charlie, thanks for the info. Did yours screw betweened the trans cable and the speedo cable? Was it a GM new or used and what year. This is a Mass Tech . I do not care what it is if it works.

Thanks

Rich

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...