Jump to content

Horn not ALWAYS working??


avantifred
 Share

Recommended Posts

Have you ever had a problem where the horn doesn't always "beep"? Assuming the horns & the relay are good !!

You may move the steering wheel just a little & it sometimes works !

You took the steering wheel off a dozen times & still no solution to the problem!!

By now you (like me) are clueless !!

If this sounds familiar & you reply to this post I'll give you the Jon Meyer absolute solution !!

Link to comment
Share on other sites

  • 2 weeks later...

I almost didn't get my insurance inspection passed because of this. When told about it by the inspector I turned the wheel a bit and the horn went "beep" when tried. The inspector shook his head but passed the car.

Edited by StudeNorm
Link to comment
Share on other sites

StudeNorm: Do you want to know the permanent fix........or has it already been fixed?

If you must turn the steering wheel just a little bit to hear the horn - IT IS NOT FIXED !!

Link to comment
Share on other sites

MFG is right .A jumper cable can be installed from below attached to one of the bolts at the rag joint.

In my case it was Jon Meyer to the rescue !!

Link to comment
Share on other sites

Thanks, guys. This sounds like the fix I will be using. It will be taken care of soon. Along with a release bearing to change and a carb to rebuild, and a power steering pump to rebuild, and a rear main seal to replace, and a (blah blah blah)...

And my font on this reply looks teeny tiny but I won't change it on this computer because it might actually be OK.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...