Jump to content

Overhead switches...


Recommended Posts

I spent some “quality” time in the car, in the garage with the lights off (yes, my wife thinks I'm nuts), seeing what the various switches are (and aren’t) doing.

#1 Turns headlights on

#2 Driving (or parking?) lights come on ( the front turn indicators). The panel reads "Pk" & "DR". What do they mean? Parking lights and driving (literally normal driving with headlights or auxillary driving/fog lights?).

#3 Turns on overhead panel light

#4 Turn on instrument lights…but only if switches #1 & 3 are on …High only, not low & high as marked on switch & owners manual.

#5 blower power only...no noise.

#6 Blower high…no low

How does that sound?

Is that stuff normal or has some previous owner messed it up?

Would new switches fix the problems?

Help!!! I wish someone would publish "Avantis for Dummies".

Link to post
Share on other sites
I spent some “quality” time in the car, in the garage with the lights off (yes, my wife thinks I'm nuts), seeing what the various switches are (and aren’t) doing.

#1 Turns headlights on.

CORRECT

#2 Driving (or parking?) lights come on ( the front turn indicators). The panel reads "Pk" & "DR". What do they mean? Parking lights and driving (literally normal driving with headlights or auxillary driving/fog lights?).

THIS SWITCHES BETWEEN YOUR HEADLIGHTS AND RUNNING LIGHTS. "DR" IS FOR HEADLIGHTS..."PK" IS FOR PARKING (OR RUNNING) LIGHTS. IT HAS NOTHING TO DO WITH AUXILIARY DRIVING/FOG LIGHTS.

#3 Turns on overhead panel light

NO...IT TURNS ON YOUR INSTRUMENT LIGHTS AND RADIO DIAL INDICATOR LIGHT.

#4 Turn on instrument lights…but only if switches #1 & 3 are on …High only, not low & high as marked on switch & owners manual.

THIS SHOULD EITHER DIM OR BRIGHTEN YOUR DASH LIGHTS...TWO SETTINGS ONLY. ONLY IF #1 AND #3 ARE ON AS YOU SAID.

#5 blower power only...no noise.

YES...IT TURNS THE BLOWER FAN ON AND OFF.

#6 Blower high…no low

IT SHOULD BE HIGH AND LOW.

How does that sound?

Is that stuff normal or has some previous owner messed it up?

Would new switches fix the problems?

Help!!! I wish someone would publish "Avantis for Dummies".

It sounds like you may have connection or ground problems WITH #6. These switches don't often go bad, but they are nearly fifty years old so anything is possible. From what I've seen, they discolor from age long before they go bad. I would take the switches out and check the connections. Use a test light to see if power is coming out of the low blower terminal. Since you said you have high blower the switch is getting power. If nothing is coming out of the low setting, replace the switch. If you have power from that side, you need to look elsewhere for the problem.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...