Jump to content

Search the Community

Showing results for tags 'electrical'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General discussion
    • Avanti Trivia
    • Avanti Pub
  • Avanti Chat
    • 1963-64 Avanti
    • 1966-83 Avanti
    • 1984-91 Avanti
    • 2000-2007 Avanti models
    • All AVX models
  • Parts & Service
    • Avanti Information
    • Studebaker Information
  • Classified
    • Avanti's For Sale
    • Avanti Parts
    • Studebaker Parts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


My Avanti

Found 2 results

  1. What are others using for quality low current, high vision headlights using H4 tech lamps. Don't want to add relays and keep the factory wiring "as is." Thanks Anyone using this site: https://www.carid.com/1963-studebaker-avanti-factory-headlights/
  2. As I was driving my 63 Avanti home from the Studebaker Swap Meet in Dunkirk Friday, I caught up into a monsoon. I quickly realized that the wipers while prefect for a light rain were no match for a heavy rain. They work properly and reset but have only one speed. No matter where I turn the knob, the wiper speed does not seem to increase. Is this a wiper motor or a rheostat switch problem?
×
×
  • Create New...