Jump to content

Oil Pressure


DAPY
 Share

Recommended Posts

At idle when hot the oil pressure in my 1982/305 drops close to "0". Engine accelerates well and runs smoothly in all regimes. Makes no unusual noises. Has 30K miles. Does not overheat or use oil. Should I worry? Use thicker oil? 

Link to comment
Share on other sites

I had a similar issue with my '76 (400 SBC)a few years back.  Your mechanic should be able to easily check the accuracy of your gauge.  My gauge was accurate.  Pressure was anywhere from 28-36 at highway speed and down to nearly 0 idling.  My pressure issue was solved by finding a couple other issues with the motor and having it rebuilt.  Pressure at highway speeds is now at 52.

Link to comment
Share on other sites

So it wasn't your gauge. Since my engine is the 305 with only 35K miles with good compression I do not want to have it rebuilt. Replaced maybe with a rebuilt 350. What is the continuing risk?

Link to comment
Share on other sites

I would use 10W30 oil and as long as your engine maintains at least five psi, I would just run it.  In the days of idiot lights, many engines idled at very low pressures and the owner did not know it.

Link to comment
Share on other sites

16 hours ago, DAPY said:

What would be a "gauge of known accuracy"? I'm not mechanical.

Any well equipped repair shop should have a calibrated pressure gauge. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...