Jump to content
Sign in to follow this  
Kennie B.

Tachometer stops at 2000rpm

Recommended Posts

Well, what did I do wrong?

 I had the dash out of my car to clean up the instrument's chrome rings and re-finish the vinyl.

As such, I had to disconnect all the wiring.  Upon reinstalling everything, it all works except for the tach.  At idle it reads fine but stops advancing at 2000rpm.  Did I mix up 2 wires or did disturbing the sender from its 50 year perch mess things up?

Thanks,

Ken

Share this post


Link to post
Share on other sites

 

Did you disconnect the battery before removing the wiring?  Of all things electrical under the dash, the tach sender is one of the most sensitive.

 

Share this post


Link to post
Share on other sites
1 hour ago, silverstude said:

 

Did you disconnect the battery before removing the wiring?  Of all things electrical under the dash, the tach sender is one of the most sensitive.

 

Absolutely, there are way too many ways to create a short circuit back in that space. 

 

Share this post


Link to post
Share on other sites

Mine was doing same thing ,stopping at 1900 , pulled out the tach (not easy )and the top bulb had fallen out of the holder , does your dash lights all illuminate properly ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...