Jump to content
Sign in to follow this  
R2W55

Coil Springs

Recommended Posts

I am now putting my 78 back together! But something does not seem right!

I replaced the Front Coils springs with Moog CC653, variable rate springs. I had read a couple of articles on Avanti Websites sites that said these were a good replacement. The Moog CC655 were the recommended but are no longer available.

I replaced all the bushings, rebuilt the kingpins and reassembled the upper and lower control arms (no engine or body yet) using a chain around the frame and floor jack (actually a truckers strap) to compress the spring and reassemble the king pins.  All went well. As expected, with no weight on the frame, the upper control arm bumper was sitting on the frame.

I have put the engine and transmission back on the frame. I expected at this point to see some compression of the spring.  NONE!  With a jack stand under the lower control arm, and pushing down on the frame, I still do not get any compression.  I again put the floor jack under the lower control arm and wrapped a chain around it and the frame.  I can get compression this way. The upper/lower control arms do move up and down as expected.

Does this sound normal?  Is the body going to add that much more weight? Did I order the wrong springs?

Share this post


Link to post
Share on other sites

I would say you sussed it out at too much compression. Here's the 655's without much road time on my 74 and they compress. 

1oztIUn.jpg

Share this post


Link to post
Share on other sites

You should not tighten up the bushings, etc. until you have full weight on the front end.

Share this post


Link to post
Share on other sites

Thanks.  That eases my mind.  I would hate o have to disassemble the control arms again to replace. just curious, about how much distance is there between your frame and the upper control arm bumper?

Share this post


Link to post
Share on other sites

I just double checked and the bushings have not been tightened yet. I just checked with a MOOG Representative and the 2 springs are compatible. 

I guess I'll have to wait until I get the body back on.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...